Error: Workshop! Only leave vehicle in position P

Volkswagen taking the biscuit

Within weeks of buying my car, a four-year old 2015 Volkswagen Polo 1.2 TSI SE 5d DSG, I discovered that I would occasionally be presented with an error message while driving stating “Error: Workshop! Only leave vehicle in position P.

Although most of the time the audible tone and error message would disappear within five to ten seconds, it was disconcerting all the same, and a distraction while driving. For a long time I’ve been a “Do Not Disturb While Driving” convert, making use of iOS’s ability to silence notifications while I’m in the car. An alert that beeps and lights up your dashboard with a warning light is dangerous in its own right. If my car incorrectly thinks it’s in the workshop, or my gear shift should be somewhere else, that’s dangerous too.

Like any good millennial, I googled the error message and quickly found forum posts from other VW owners who’d seen the same message. The consensus was that it was caused by a faulty gear selector, and since it’s a known manufacturing fault, the forum posts informed me VW have a service bulletin out and their technicians should be able to identify and rectify the problem swiftly. Knowing I had one year’s warranty included with my purchase, I booked my car into the VW garage I’d bought the car from, who after a couple of hours told me they couldn’t find anything wrong. They said to see if it happens again and bring it back if it did. They left me their standard complimentary biscuit and I was sent on my way. Surprised by this, but trusting Volkswagen (and enjoying my sugar fix), I went away hoping the error, which had only occurred two or three times, would go away by itself.

Skip forward a few months and the error had reoccurred, and I’d also seen estimates that the cost of a new gear selector could run into the thousands. The error had kept happening every few weeks. At the same time I’d noticed my coolant kept dropping down below it’s expected level: I had a slow leak in my cooling system. When I booked this in to get fixed under warranty, I asked them to look at the “workshop!” error too. Again, they found nothing, but did replace my cooling system, over a thousand pounds worth of repairs. Surprising for a car that was only four years old, I was grateful for the warranty and another complimentary biscuit.

A month or two later, the message starting appearing more frequently. I booked it in again, keen to get it resolved before my one year warranty expired (even though as a manufacturing fault, VW should really cover it anyway). This time I told the them there were many forum posts stating it was probably the gear selector, and showed them a video I’d taken of the error (this was difficult to do without breaking the law, but thankfully on at least one occasion the error remained until I was parked off the road and able to take a photo).

After a having the car for a few hours, I was the told the error could be fixed by a software update to my infotainment system, and that as software isn’t covered under warranty I’d have to pay a £110 diagnostic fee. Even after explaining the forum posts saying it’s the gear selector, they insisted it was a software problem. Not happy about having to pay to fix a fault, I insisted I shouldn’t have to pay. The garage wouldn’t budge, stating that the warranty only covers mechanical and electrical faults. Even when I explained that software is powered by electricity and so is technically electrical, they refused to waive the fee. In the end I had to phone Volkswagen HQ, and after expressing my frustration and disappointment in Volkswagen in no uncertain terms, they were able to convince the garage to let me off the fee as a “goodwill gesture”.

While doubtful the software update would resolve the problem, I gave the technicals who work for Volkswagen the benefit of the doubt and hoped they had finally fixed this annoying and dangerous error message. I also got a another biscuit.

About a week after this, the alert showed again. In fact, it now started showing up more frequently. Sometimes multiple times in one journey, and sometimes not disappearing until I stopped the car and restarted the engine. I phoned Volkswagen again, this time in full “angry consumer” mode and, exacerbated by their inability to fix an issue that a simple web search returns a solution for.

For the fourth time, I dropped my car off. They had preordered a replacement gear selector this time, and so I was quietly confident it would be fixed. About six hours after handing over my car, I received a phone call informing that they had indeed found it was the gear selector and there was even a technical bulletin about this very fault. Thankfully there was no difference of opinion with warranty cover. 10 months into my 12 month warranty, I was reassured.

This was two days ago. I’ve not seen the message since. My fingers are crossed that this will indeed fix it, but after this experience, in all honesty, I’m not holding my breath. I think they’ve given up with the biscuits now. It’s disappointing but probably better for my health considering how many times I’ve had to go back.

If you experience this error, don’t give up. Mine got worse over time, so get it fixed- no matter how many times they push you away with free confectionary. It’s the gear selector!

Advertisements